Bulletin d'alerte Debian

DSA-4044-1 swauth -- Mise à jour de sécurité

Date du rapport :
21 novembre 2017
Paquets concernés :
swauth
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 882314.
Dans le dictionnaire CVE du Mitre : CVE-2017-16613.
Plus de précisions :

Une vulnérabilité a été découverte dans swauth, un système d'authentification pour Swift, un stockage objet virtuel distribué utilisé dans Openstack.

Le jeton d'authentification d'un utilisateur est sauvegardé en clair dans le fichier journal, ce qui pourrait permettre à un attaquant doté d'un accès aux journaux de contourner l'authentification fournie par swauth.

Pour la distribution stable (Stretch), ce problème a été corrigé dans la version 1.2.0-2+deb9u1.

Nous vous recommandons de mettre à jour vos paquets swauth.

Pour disposer d'un état détaillé sur la sécurité de swauth, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/swauth