Debians sikkerhedsbulletin

DSA-4052-1 bzr -- sikkerhedsopdatering

Rapporteret den:
29. nov 2017
Berørte pakker:
bzr
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 874429.
I Mitres CVE-ordbog: CVE-2017-14176.
Yderligere oplysninger:

Adam Collard opdagede at Bazaar, et letanvendeligt distribueret versionskontrolsystem, ikke på korrekt vis håndterede ondsindet fremstillede bzr+ssh-URL'er, hvilket gjorde det muligt for en fjernangriber at køre en vilkårlig shell-kommando.

I den gamle stabile distribution (jessie), er dette problem rettet i version 2.6.0+bzr6595-6+deb8u1.

I den stabile distribution (stretch), er dette problem rettet i version 2.7.0+bzr6619-7+deb9u1.

Vi anbefaler at du opgraderer dine bzr-pakker.

For detaljeret sikkerhedsstatus vedrørende bzr, se dens sikkerhedssporingsside på: https://security-tracker.debian.org/tracker/bzr