Bulletin d'alerte Debian

DSA-4052-1 bzr -- Mise à jour de sécurité

Date du rapport :
29 novembre 2017
Paquets concernés :
bzr
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 874429.
Dans le dictionnaire CVE du Mitre : CVE-2017-14176.
Plus de précisions :

Adam Collard a découvert que Bazaar, un système de gestion de versions décentralisé facile à utiliser, ne gérait pas correctement des URL bzr+ssh construites de façon malveillante, permettant à un attaquant distant d'exécuter une commande arbitraire de l'interpréteur.

Pour la distribution oldstable (Jessie), ce problème a été corrigé dans la version 2.6.0+bzr6595-6+deb8u1.

Pour la distribution stable (Stretch), ce problème a été corrigé dans la version 2.7.0+bzr6619-7+deb9u1.

Nous vous recommandons de mettre à jour vos paquets bzr.

Pour disposer d'un état détaillé sur la sécurité de bzr, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/bzr