Рекомендация Debian по безопасности

DSA-4052-1 bzr -- обновление безопасности

Дата сообщения:
29.11.2017
Затронутые пакеты:
bzr
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 874429.
В каталоге Mitre CVE: CVE-2017-14176.
Более подробная информация:

Адам Коллар обнаружил, что Bazaar, простая в использовании распределённая система управления версиями, неправильно обрабатывает специально сформированные URL вида bzr+ssh, что позволяет удалённому злоумышленнику запускать произвольные команды командной оболочки.

В предыдущем стабильном выпуске (jessie) эта проблема была исправлена в версии 2.6.0+bzr6595-6+deb8u1.

В стабильном выпуске (stretch) эта проблема была исправлена в версии 2.7.0+bzr6619-7+deb9u1.

Рекомендуется обновить пакеты bzr.

С подробным статусом поддержки безопасности bzr можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/bzr