Säkerhetsbulletin från Debian

DSA-4052-1 bzr -- säkerhetsuppdatering

Rapporterat den:
2017-11-29
Berörda paket:
bzr
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Debians felrapporteringssystem: Fel 874429.
I Mitres CVE-förteckning: CVE-2017-14176.
Ytterligare information:

Adam Collard upptäckte att Bazaar, ett lättanvänt distribuerat versionshanteringssystem, inte hanterar illasinnat konstruerade bzr+ssh-URLer ordentligt, vilket tillåter fjärrangripare att köra ett godtycklig skalkommando.

För den gamla stabila utgåvan (Jessie) har detta problem rättats i version 2.6.0+bzr6595-6+deb8u1.

För den stabila utgåvan (Stretch) har detta problem rättats i version 2.7.0+bzr6619-7+deb9u1.

Vi rekommenderar att ni uppgraderar era bzr-paket.

För detaljerad säkerhetsstatus om bzr vänligen se dess säkerhetsspårare på: https://security-tracker.debian.org/tracker/bzr