Рекомендация Debian по безопасности

DSA-4053-1 exim4 -- обновление безопасности

Дата сообщения:
30.11.2017
Затронутые пакеты:
exim4
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 882648, Ошибка 882671.
В каталоге Mitre CVE: CVE-2017-16943, CVE-2017-16944.
Более подробная информация:

В Exim, агенте передачи электронной почты, было обнаружено несколько уязвимостей. Проект Common Vulnerabilities and Exposures определяет следующие проблемы:

  • CVE-2017-16943

    В функциях Exim, используемых для выполнения грамматического разбора почтовых заголовков было обнаружено использование указателей после освобождения памяти. Удалённый злоумышленник может использовать эту уязвимость для аварийного завершения работы Exim, что приводит к отказу в обслуживании или потенциальному удалённому выполнению кода.

  • CVE-2017-16944

    Было обнаружено, что Exim неправильно обрабатывает заголовки BDAT-данных, позволяя удалённому злоумышленнику аварийно завершать работу Exim, что приводит к отказу в обслуживании.

В стабильном выпуске (stretch) эти проблемы были исправлены в версии 4.89-2+deb9u2. В настройках по умолчанию объявление расширения ESMTP CHUNKING отключено, поэтому данные уязвимости не актуальны.

Рекомендуется обновить пакеты exim4.

С подробным статусом поддержки безопасности exim4 можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/exim4