Debian Security Advisory

DSA-4056-1 nova -- security update

Date Reported:
07 Dec 2017
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 882009.
In Mitre's CVE dictionary: CVE-2017-16239.
More information:

George Shuklin from discovered that Nova, a cloud computing fabric controller, did not correctly enforce its image- or hosts-filters. This allowed an authenticated user to bypass those filters by simply rebuilding an instance.

For the stable distribution (stretch), this problem has been fixed in version 2:14.0.0-4+deb9u1.

We recommend that you upgrade your nova packages.

For the detailed security status of nova please refer to its security tracker page at: