Рекомендация Debian по безопасности

DSA-4058-1 optipng -- обновление безопасности

Дата сообщения:
08.12.2017
Затронутые пакеты:
optipng
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 878839, Ошибка 882032.
В каталоге Mitre CVE: CVE-2017-16938, CVE-2017-1000229.
Более подробная информация:

В optipng, продвинутой утилите для оптимизации PNG, были обнаружены две уязвимости, которые могут приводить к отказу в обслуживании или выполнению произвольного кода в случае обработки специально сформированного файл.

В предыдущем стабильном выпуске (jessie) эти проблемы были исправлены в версии 0.7.5-1+deb8u2.

В стабильном выпуске (stretch) эти проблемы были исправлены в версии 0.7.6-1+deb9u1.

Рекомендуется обновить пакеты optipng.

С подробным статусом поддержки безопасности optipng можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/optipng