Säkerhetsbulletin från Debian

DSA-4058-1 optipng -- säkerhetsuppdatering

Rapporterat den:
2017-12-08
Berörda paket:
optipng
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Debians felrapporteringssystem: Fel 878839, Fel 882032.
I Mitres CVE-förteckning: CVE-2017-16938, CVE-2017-1000229.
Ytterligare information:

Två sårbarheter upptäcktes i optipng, en avancerad PNG-optimerare, vilket kan leda till överbelastning eller exekvering av godtycklig kod om en felaktigt formatterad fil behandlas.

För den gamla stabila utgåvan (Jessie) har dessa problem rättats i version 0.7.5-1+deb8u2.

För den stabila utgåvan (Stretch) har dessa problem rättats i version 0.7.6-1+deb9u1.

Vi rekommenderar att ni uppgraderar era optipng-paket.

För detaljerad säkerhetsstatus om optipng vänligen se dess säkerhetsspårare på: https://security-tracker.debian.org/tracker/optipng