Рекомендация Debian по безопасности

DSA-4059-1 libxcursor -- обновление безопасности

Дата сообщения:
08.12.2017
Затронутые пакеты:
libxcursor
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 883792.
В каталоге Mitre CVE: CVE-2017-16612.
Более подробная информация:

Было обнаружено, что libXcursor, библиотека управления курсором для X, уязвима к нескольким переполнениям динамической памяти, возникающим при выполнении грамматического разбора специально сформированных файлов. Злоумышленник может использовать эти уязвимости для выполнения произвольного кода в случае, если пользователь запустит обработку специально сформированного файла курсора.

В предыдущем стабильном выпуске (jessie) эти проблемы были исправлены в версии 1:1.1.14-1+deb8u1.

В стабильном выпуске (stretch) эти проблемы были исправлены в версии 1:1.1.14-1+deb9u1.

Рекомендуется обновить пакеты libxcursor.

С подробным статусом поддержки безопасности libxcursor можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/libxcursor