Debian Security Advisory

DSA-4071-1 sensible-utils -- security update

Date Reported:
21 Dec 2017
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 881767.
In Mitre's CVE dictionary: CVE-2017-17512.
More information:

Gabriel Corona reported that sensible-browser from sensible-utils, a collection of small utilities used to sensibly select and spawn an appropriate browser, editor or pager, does not validate strings before launching the program specified by the BROWSER environment variable, potentially allowing a remote attacker to conduct argument-injection attacks if a user is tricked into processing a specially crafted URL.

For the oldstable distribution (jessie), this problem has been fixed in version 0.0.9+deb8u1.

For the stable distribution (stretch), this problem has been fixed in version 0.0.9+deb9u1.

We recommend that you upgrade your sensible-utils packages.

For the detailed security status of sensible-utils please refer to its security tracker page at: