Debian Security Advisory

DSA-4072-1 bouncycastle -- security update

Date Reported:
21 Dec 2017
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2017-13098.
More information:

Hanno Boeck, Juraj Somorovsky and Craig Young discovered that the TLS implementation in Bouncy Castle is vulnerable to an adaptive chosen ciphertext attack against RSA keys.

For the stable distribution (stretch), this problem has been fixed in version 1.56-1+deb9u1.

We recommend that you upgrade your bouncycastle packages.

For the detailed security status of bouncycastle please refer to its security tracker page at: