Рекомендация Debian по безопасности

DSA-4074-1 imagemagick -- обновление безопасности

Дата сообщения:
28.12.2017
Затронутые пакеты:
imagemagick
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2017-12877, CVE-2017-16546, CVE-2017-17499, CVE-2017-17504, CVE-2017-17879.
Более подробная информация:

В данном обновлении исправлено несколько уязвимостей в imagemagick. Различные проблемы работы с памятью, а также случаи отсутствия или неполной очистки входных данных могут приводить к отказу в обслуживании, раскрытию содержимого памяти или выполнению произвольного кода в случае обработки специально сформированных файлов изображений.

В стабильном выпуске (stretch) эти проблемы были исправлены в версии 8:6.9.7.4+dfsg-11+deb9u4.

Рекомендуется обновить пакеты imagemagick.

С подробным статусом поддержки безопасности imagemagick можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/imagemagick