Bulletin d'alerte Debian

DSA-4081-1 php5 -- Mise à jour de sécurité

Date du rapport :
8 janvier 2018
Paquets concernés :
php5
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2017-11142, CVE-2017-11143, CVE-2017-11144, CVE-2017-11145, CVE-2017-11628, CVE-2017-12933, CVE-2017-16642.
Plus de précisions :

Plusieurs vulnérabilités ont été découvertes dans PHP, un langage de script généraliste à source libre couramment utilisé :

  • CVE-2017-11142

    déni de service grâce à des variables de formulaire excessivement longues

  • CVE-2017-11143

    libération de zone de mémoire (free()) non valable dans wddx_deserialize()

  • CVE-2017-11144

    déni de service dans l'extension openssl dû à une vérification incorrecte de la valeur de retour de la fonction de scellement d'OpenSSL

  • CVE-2017-11145

    lecture hors limites dans wddx_deserialize()

  • CVE-2017-11628

    dépassement de tampon dans l'API d'analyse de PHP INI

  • CVE-2017-12933

    lecture hors limites de tampon dans finish_nested_data()

  • CVE-2017-16642

    lecture hors limites dans timelib_meridian()

Pour la distribution oldstable (Jessie), ces problèmes ont été corrigés dans la version 5.6.33+dfsg-0+deb8u1.

Nous vous recommandons de mettre à jour vos paquets php5.

Pour disposer d'un état détaillé sur la sécurité de php5, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/php5