Рекомендация Debian по безопасности

DSA-4083-1 poco -- обновление безопасности

Дата сообщения:
11.01.2018
Затронутые пакеты:
poco
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2017-1000472.
Более подробная информация:

Штефан Цайсберг обнаружил, что poco, набор библиотек с открытым исходным кодом с классами для C++, неправильно выполняет проверку путей файлов в ZIP-архивах.. Злоумышленник может использовать эту уязвимость для создания или перезаписи произвольных файлов.

В предыдущем стабильном выпуске (jessie) эта проблема была исправлена в версии 1.3.6p1-5+deb8u1.

В стабильном выпуске (stretch) эта проблема была исправлена в версии 1.7.6+dfsg1-5+deb9u1.

Рекомендуется обновить пакеты poco.

С подробным статусом поддержки безопасности poco можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/poco