Debian Security Advisory

DSA-4085-1 xmltooling -- security update

Date Reported:
12 Jan 2018
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2018-0486.
More information:

Philip Huppert discovered the Shibboleth service provider is vulnerable to impersonation attacks and information disclosure due to mishandling of DTDs in the XMLTooling XML parsing library. For additional details please refer to the upstream advisory at

For the oldstable distribution (jessie), this problem has been fixed in version 1.5.3-2+deb8u2.

The stable distribution (stretch) is not affected.

We recommend that you upgrade your xmltooling packages.

For the detailed security status of xmltooling please refer to its security tracker page at: