데비안 보안 권고

DSA-4086-1 libxml2 -- 보안 업데이트

보고일:
2018년 01월 13일
영향 받는 패키지:
libxml2
위험성:
보안 데이터베이스 참조:
데비안 버그 추적 시스템: 버그 883790.
Mitre의 CVE 사전: CVE-2017-15412.
추가 정보:

Nick Wellnhofer는 XPath 조건(predicate) 안의 어떤 함수 호출이 XSLT 변환을 통한 libxml2의 XPath 엔진에 의해 실행될 때 use-after-free와 double-free error가 날 수 있음을 발견했습니다.

옛 안정 배포판(jessie)에서, 이 문제는 2.9.1+dfsg1-5+deb8u6 버전에서 수정되었습니다.

안정 버전(stretch)에서, 이 문제는 2.9.4+dfsg1-2.2+deb9u2 버전에서 수정되었습니다.

libxml2 패키지를 업그레이드 할 것을 권합니다.

libxml2의 자세한 보안 상태는 아래의 보안 추적 페이지를 참고하세요: https://security-tracker.debian.org/tracker/libxml2