Рекомендация Debian по безопасности

DSA-4086-1 libxml2 -- обновление безопасности

Дата сообщения:
13.01.2018
Затронутые пакеты:
libxml2
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 883790.
В каталоге Mitre CVE: CVE-2017-15412.
Более подробная информация:

Ник Уэлнхофер обнаружил, что некоторые вызовы функций в предикатах XPath могут приводить к использованию указателей после освобождения памяти или двойному освобождению памяти при выполнении движка XPath из состава libxml2 путём преобразования XSLT.

В предыдущем стабильном выпуске (jessie) эта проблема была исправлена в версии 2.9.1+dfsg1-5+deb8u6.

В стабильном выпуске (stretch) эта проблема была исправлена в версии 2.9.4+dfsg1-2.2+deb9u2.

Рекомендуется обновить пакеты libxml2.

С подробным статусом поддержки безопасности libxml2 можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/libxml2