Рекомендация Debian по безопасности

DSA-4104-1 p7zip -- обновление безопасности

Дата сообщения:
04.02.2018
Затронутые пакеты:
p7zip
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 888297.
В каталоге Mitre CVE: CVE-2017-17969.
Более подробная информация:

'landave' обнаружил переполнение динамической памяти в методе NCompress::NShrink::CDecoder::CodeReal в p7zip, архиваторе файлов 7zr с высокой степенью сжатия. Удалённый злоумышленник может использовать эту уязвимость для вызова отказа в обслуживании или потенциального выполнения произвольного кода с правами пользователя, запустившего p7zip в случае обработки специально сформированного сокращённого ZIP-архива.

В предыдущем стабильном выпуске (jessie) эта проблема была исправлена в версии 9.20.1~dfsg.1-4.1+deb8u3.

В стабильном выпуске (stretch) эта проблема была исправлена в версии 16.02+dfsg-3+deb9u1.

Рекомендуется обновить пакеты p7zip.

С подробным статусом поддержки безопасности p7zip можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/p7zip