Debian Security Advisory

DSA-4114-1 jackson-databind -- security update

Date Reported:
15 Feb 2018
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 888316, Bug 888318.
In Mitre's CVE dictionary: CVE-2017-17485, CVE-2018-5968.
More information:

It was discovered that jackson-databind, a Java library used to parse JSON and other data formats, did not properly validate user input before attempting deserialization. This allowed an attacker to perform code execution by providing maliciously crafted input.

For the oldstable distribution (jessie), these problems have been fixed in version 2.4.2-2+deb8u3.

For the stable distribution (stretch), these problems have been fixed in version 2.8.6-1+deb9u3.

We recommend that you upgrade your jackson-databind packages.

For the detailed security status of jackson-databind please refer to its security tracker page at: