Debian Security Advisory

DSA-4116-1 plasma-workspace -- security update

Date Reported:
16 Feb 2018
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2018-6791.
More information:

Krzysztof Sieluzycki discovered that the notifier for removable devices in the KDE Plasma workspace performed insufficient sanitisation of FAT/VFAT volume labels, which could result in the execution of arbitrary shell commands if a removable device with a malformed disk label is mounted.

For the stable distribution (stretch), this problem has been fixed in version 4:5.8.6-2.1+deb9u1.

We recommend that you upgrade your plasma-workspace packages.

For the detailed security status of plasma-workspace please refer to its security tracker page at: