Aviso de seguridad de Debian

DSA-4122-1 squid3 -- actualización de seguridad

Fecha del informe:
23 de feb de 2018
Paquetes afectados:
squid3
Vulnerable:
Referencias a bases de datos de seguridad:
En el sistema de seguimiento de errores de Debian: error 888719, error 888720.
En el diccionario CVE de Mitre: CVE-2018-1000024, CVE-2018-1000027.
Información adicional:

Se han descubierto varias vulnerabilidades en Squid3, un proxy web caché con funciones completas. El proyecto «Vulnerabilidades y exposiciones comunes» («Common Vulnerabilities and Exposures») identifica los problemas siguientes:

  • CVE-2018-1000024

    Louis Dion-Marcil descubrió que Squid no procesa correctamente ciertas respuestas ESI. Un servidor remoto que distribuya respuestas ESI con determinada sintaxis puede aprovechar este defecto para provocar denegación de servicio a todos los clientes que accedan al servicio Squid. Este problema está limitado al analizador ESI custom de Squid.

    http://www.squid-cache.org/Advisories/SQUID-2018_1.txt

  • CVE-2018-1000027

    Louis Dion-Marcil descubrió que Squid es propenso a una vulnerabilidad de denegación de servicio al procesar respuestas ESI y al descargar certificados intermediarios de CA. Un atacante remoto puede aprovechar este defecto para provocar denegación de servicio a todos los clientes que accedan al servicio Squid.

    http://www.squid-cache.org/Advisories/SQUID-2018_2.txt

Para la distribución «antigua estable» (jessie), estos problemas se han corregido en la versión 3.4.8-6+deb8u5.

Para la distribución «estable» (stretch), estos problemas se han corregido en la versión 3.5.23-5+deb9u1.

Le recomendamos que actualice los paquetes de squid3.

Para información detallada sobre el estado de seguridad de squid3 consulte su página del «security tracker» en: https://security-tracker.debian.org/tracker/squid3