Рекомендация Debian по безопасности

DSA-4130-1 dovecot -- обновление безопасности

Дата сообщения:
02.03.2018
Затронутые пакеты:
dovecot
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 888432, Ошибка 891819, Ошибка 891820.
В каталоге Mitre CVE: CVE-2017-14461, CVE-2017-15130, CVE-2017-15132.
Более подробная информация:

В Dovecot, сервере электронной почты, было обнаружено несколько уязвимостей. Проект Common Vulnerabilities and Exposures определяет следующие проблемы:

  • CVE-2017-14461

    Александр Николич из Cisco Talos и flxflndy обнаружили, что Dovecot неправильно выполняет грамматический разбор адресов электронной почты, что может вызывать аварийную остановку или утечку содержимого памяти злоумышленнику.

  • CVE-2017-15130

    Было обнаружено, что преобразование настройки TLS SNI может приводить к чрезмерному потреблению памяти, приводящему к достижению ограничения imap-login/pop3-login VSZ и перезапуску процесса, что приводит к отказу в обслуживании. Этой уязвимости подвержен только Dovecot, настройки которого содержат блоки local_name { } или local { }.

  • CVE-2017-15132

    Было обнаружено, что Dovecot содержит утечку памяти в процессе входа, которая возникает при преждевременном прекращении SASL-аутентификации.

В предыдущем стабильном выпуске (jessie) эти проблемы были исправлены в версии 1:2.2.13-12~deb8u4.

В стабильном выпуске (stretch) эти проблемы были исправлены в версии 1:2.2.27-3+deb9u2.

Рекомендуется обновить пакеты dovecot.

С подробным статусом поддержки безопасности dovecot можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/dovecot