Рекомендация Debian по безопасности

DSA-4131-1 xen -- обновление безопасности

Дата сообщения:
04.03.2018
Затронутые пакеты:
xen
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2018-7540, CVE-2018-7541, CVE-2018-7542.
Более подробная информация:

В гипервизоре Xen, были обнаружены многочисленные уязвимости:

  • CVE-2018-7540

    Ян Хорн обнаружил, что отсутствие проверок в коде очистки таблицы переадресации страниц может приводить к отказу в обслуживании.

  • CVE-2018-7541

    Ян Бёлих обнаружил, что неправильная обработка ошибок в коде проверки таблицы предоставлений может приводить к отказу в обслуживании по типу гостевая система — главная система и потенциальному повышению привилегий.

  • CVE-2018-7542

    Иэн Джексон обнаружил, что недостаточная обработка гостевых систем x86 PVH без локальных APIC может приводить к отказу в обслуживании по типу гостевая система — главная система.

В стабильном выпуске (stretch) эти проблемы были исправлены в версии 4.8.3+comet2+shim4.10.0+comet3-1+deb9u5.

Рекомендуется обновить пакеты xen.

С подробным статусом поддержки безопасности xen можно ознакомиться на соответствующей странице отслеживания безопасности https://security-tracker.debian.org/tracker/xen