Bulletin d'alerte Debian

DSA-4142-1 uwsgi -- Mise à jour de sécurité

Date du rapport :
17 mars 2018
Paquets concernés :
uwsgi
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 891639.
Dans le dictionnaire CVE du Mitre : CVE-2018-7490.
Plus de précisions :

Marios Nicolaides a découvert que le greffon PHP dans uWSGI, un serveur de conteneurs d'application rapide et autoréparateur, ne gérait pas correctement une vérification de DOCUMENT_ROOT durant l'utilisation de l'option --php-docroot, permettant à un attaquant distant de monter une attaque de traversée de répertoires et d'obtenir un accès en lecture non autorisé à des fichiers sensibles situés en dehors du répertoire racine web.

Pour la distribution oldstable (Jessie), ce problème a été corrigé dans la version 2.0.7-1+deb8u2. De plus cette mise à jour, comprend le correctif pour CVE-2018-6758 qui était destiné à être traité dans la version intermédiaire à venir de Jessie.

Pour la distribution stable (Stretch), ce problème a été corrigé dans la version 2.0.14+20161117-3+deb9u2.

Nous vous recommandons de mettre à jour vos paquets uwsgi.

Pour disposer d'un état détaillé sur la sécurité de uwsgi, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/uwsgi