Debians sikkerhedsbulletin

DSA-4151-1 librelp -- sikkerhedsopdatering

Rapporteret den:
26. mar 2018
Berørte pakker:
librelp
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2018-1000140.
Yderligere oplysninger:

Bas van Schaik og Kevin Backhouse opdagede en stakbaseret bufferoverløbssårbarhed i librelp, et bibliotek der stiller en pålidelig eventlogning over netværket til rådighed, som blev udløst mens der blev kontrolleret x509-certifikater fra en peer. En fjernangrier, der er i stand til at forbinde sig til rsyslog, kunne drage nytte af fejlen til fjernudførelse af kode, ved at sende et særligt fremstillet x509-certifikat.

Flere oplysninger finder man i opstrøms bulletin: https://www.rsyslog.com/cve-2018-1000140/

I den gamle stabile distribution (jessie), er dette problem rettet i version 1.2.7-2+deb8u1.

I den stabile distribution (stretch), er dette problem rettet i version 1.2.12-1+deb9u1.

Vi anbefaler at du opgraderer dine librelp-pakker.

For detaljeret sikkerhedsstatus vedrørende librelp, se dens sikkerhedssporingsside på: https://security-tracker.debian.org/tracker/librelp