Aviso de seguridad de Debian

DSA-4151-1 librelp -- actualización de seguridad

Fecha del informe:
26 de mar de 2018
Paquetes afectados:
librelp
Vulnerable:
Referencias a bases de datos de seguridad:
En el diccionario CVE de Mitre: CVE-2018-1000140.
Información adicional:

Bas van Schaik y Kevin Backhouse descubrieron una vulnerabilidad por desbordamiento de pila en librelp, una biblioteca que proporciona registro («logging») fiable de eventos a través de la red, que se manifiesta durante la comprobación de certificados x509 de un par. Un atacante remoto que pueda conectarse a rsyslog puede aprovechar este defecto para ejecutar código remoto mediante el envío de un certificado x509 manipulado de una manera determinada.

El aviso del proyecto original contiene más detalles: https://www.rsyslog.com/cve-2018-1000140/

Para la distribución «antigua estable» (jessie), este problema se ha corregido en la versión 1.2.7-2+deb8u1.

Para la distribución «estable» (stretch), este problema se ha corregido en la versión 1.2.12-1+deb9u1.

Le recomendamos que actualice los paquetes de librelp.

Para información detallada sobre el estado de seguridad de librelp consulte su página del «security tracker» en: https://security-tracker.debian.org/tracker/librelp