Рекомендация Debian по безопасности

DSA-4161-1 python-django -- обновление безопасности

Дата сообщения:
01.04.2018
Затронутые пакеты:
python-django
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2018-7536, CVE-2018-7537.
Более подробная информация:

Джеймс Дэвис обнаружил две уязвимости в Django, высокоуровневой инфраструктуре веб-разработки на языке Python, которые могут приводить к отказу в обслуживании. Злоумышленник, имеющий контроль над входными данными функции django.utils.html.urlize() или методов chars() и words() объектов django.utils.text.Truncator, может сформировать строку, которая приведёт к остановке выполнения приложения.

В предыдущем стабильном выпуске (jessie) эти проблемы были исправлены в версии 1.7.11-1+deb8u3.

В стабильном выпуске (stretch) эти проблемы были исправлены в версии 1:1.10.7-2+deb9u1.

Рекомендуется обновить пакеты python-django.

С подробным статусом поддержки безопасности python-django можно ознакомиться на соответствующей странице отслеживания безопасности по адресу: https://security-tracker.debian.org/tracker/python-django