Debian Security Advisory

DSA-4169-1 pcs -- security update

Date Reported:
11 Apr 2018
Affected Packages:
pcs
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 895313.
In Mitre's CVE dictionary: CVE-2018-1086.
More information:

C├ędric Buissart from Red Hat discovered an information disclosure bug in pcs, a pacemaker command line interface and GUI. The REST interface normally doesn't allow passing --debug parameter to prevent information leak, but the check wasn't sufficient.

For the stable distribution (stretch), this problem has been fixed in version 0.9.155+dfsg-2+deb9u1.

We recommend that you upgrade your pcs packages.

For the detailed security status of pcs please refer to its security tracker page at: https://security-tracker.debian.org/tracker/pcs