Рекомендация Debian по безопасности

DSA-4172-1 perl -- обновление безопасности

Дата сообщения:
14.04.2018
Затронутые пакеты:
perl
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2018-6797, CVE-2018-6798, CVE-2018-6913.
Более подробная информация:

В реализации языка программирования Perl были обнаружены многочисленные уязвимости. Проект Common Vulnerabilities and Exposures определяет следующие проблемы:

  • CVE-2018-6797

    Брайан Карпентер сообщил, что специально сформированное регулярное выражение может вызывать переполнение динамической памяти при записи в неё, причём записываемые байты могут контролироваться злоумышленником.

  • CVE-2018-6798

    Нгуиен Дук Ман сообщил, что сравнение с регулярным выражением, зависящим от локали, может вызвать чтение за границами выделенного буфера динамической памяти и потенциальное раскрытие информации.

  • CVE-2018-6913

    ГванЕонг Ким сообщил, что функция pack() при работе с большим числом элементов может вызывать переполнение динамической памяти при записи в неё.

В предыдущем стабильном выпуске (jessie) эти проблемы были исправлены в версии 5.20.2-3+deb8u10. Обновление для предыдущего стабильного выпуска (jessie) содержит только исправление для CVE-2018-6913.

В стабильном выпуске (stretch) эти проблемы были исправлены в версии 5.24.1-3+deb9u3.

Рекомендуется обновить пакеты perl.

С подробным статусом поддержки безопасности perl можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/perl