Debians sikkerhedsbulletin

DSA-4202-1 curl -- sikkerhedsopdatering

Rapporteret den:
16. maj 2018
Berørte pakker:
curl
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 898856.
I Mitres CVE-ordbog: CVE-2018-1000301.
Yderligere oplysninger:

OSS-fuzz, med hjælp fra Max Dymond, opdagede at cURL, et URL-overførselsbibliotek, kunne narres til at læse data ud over slutningen af en heapbseret buffer, når der blev fortolket ugyldige headere i et RTSP-svar.

I den gamle stabile distribution (jessie), er dette problem rettet i version 7.38.0-4+deb8u11.

I den stabile distribution (stretch), er dette problem rettet i version 7.52.1-5+deb9u6.

Vi anbefaler at du opgraderer dine curl-pakker.

For detaljeret sikkerhedsstatus vedrørende curl, se dens sikkerhedssporingsside på: https://security-tracker.debian.org/tracker/curl