Bulletin d'alerte Debian

DSA-4202-1 curl -- Mise à jour de sécurité

Date du rapport :
16 mai 2018
Paquets concernés :
curl
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 898856.
Dans le dictionnaire CVE du Mitre : CVE-2018-1000301.
Plus de précisions :

OSS-fuzz, avec l'assistance de Max Dymond, a découvert que cURL, une bibliothèque de transfert d'URL, pourrait être entraîné à la lecture de données au-delà de la fin d'un tampon de tas lors de l'analyse d'en-têtes non valables dans les réponses RTSP.

Pour la distribution oldstable (Jessie), ce problème a été corrigé dans la version 7.38.0-4+deb8u11.

Pour la distribution stable (Stretch), ce problème a été corrigé dans la version 7.52.1-5+deb9u6.

Nous vous recommandons de mettre à jour vos paquets curl.

Pour disposer d'un état détaillé sur la sécurité de curl, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/curl.