Рекомендация Debian по безопасности

DSA-4202-1 curl -- обновление безопасности

Дата сообщения:
16.05.2018
Затронутые пакеты:
curl
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 898856.
В каталоге Mitre CVE: CVE-2018-1000301.
Более подробная информация:

Участники проекта OSS-fuzz с помощью Макса Даймонда обнаружили, что cURL, библиотека передачи URL, может производить чтение за границами выделенного буфера динамической памяти при выполнении грамматического разбора некорректных заголовков в RTSP-ответе.

В предыдущем стабильном выпуске (jessie) эта проблема была исправлена в версии 7.38.0-4+deb8u11.

В стабильном выпуске (stretch) эта проблема была исправлена в version 7.52.1-5+deb9u6.

Рекомендуется обновить пакеты curl.

С подробным статусом поддержки безопасности curl можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/curl