Debians sikkerhedsbulletin

DSA-4206-1 gitlab -- sikkerhedsopdatering

Rapporteret den:
21. maj 2018
Berørte pakker:
gitlab
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2017-0920, CVE-2018-8971.
Yderligere oplysninger:

Flere sårbarheder er opdaget i Gitlab, en softwareplatform til samarbejde om kode:

  • CVE-2017-0920

    Man opdagede at manglende validering af merge-requests gjorde det muligt for brugere at se navne på private projekter, medførende informationsafsløring.

  • CVE-2018-8971

    Man opdagede at Auth0-integrationen var implementeret forkert.

I den stabile distribution (stretch), er disse problemer rettet i version 8.13.11+dfsg1-8+deb9u2. Rettelsen af CVE-2018-8971 kræver også at ruby-omniauth-auth0 opgraderes til version 2.0.0-0+deb9u1.

Vi anbefaler at du opgraderer dine gitlab-pakker.

For detaljeret sikkerhedsstatus vedrørende gitlab, se dens sikkerhedssporingsside på: https://security-tracker.debian.org/tracker/gitlab