Debians sikkerhedsbulletin

DSA-4214-1 zookeeper -- sikkerhedsopdatering

Rapporteret den:
1. jun 2018
Berørte pakker:
zookeeper
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2018-8012.
Yderligere oplysninger:

Man opdagede at Zookeeper, en tjeneste til vedligeholdelse af opsætningsoplysninger, ikke krævede autentifikation/autorisation, når en server forsøgte at deltage i et Zookeeper-quorum.

Denne opdatering tilbagefører autentifikationsunderstøttelse. Yderligere opsætningstrin kan være nødvendige, se https://cwiki.apache.org/confluence/display/ZOOKEEPER/Server-Server+mutual+authentication for fler oplysninger.

I den gamle stabile distribution (jessie), er dette problem rettet i version 3.4.9-3+deb8u1.

I den stabile distribution (stretch), er dette problem rettet i version 3.4.9-3+deb9u1.

Vi anbefaler at du opgraderer dine zookeeper-pakker.

For detaljeret sikkerhedsstatus vedrørende zookeeper, se dens sikkerhedssporingsside på: https://security-tracker.debian.org/tracker/zookeeper