Debians sikkerhedsbulletin

DSA-4215-1 batik -- sikkerhedsopdatering

Rapporteret den:
2. jun 2018
Berørte pakker:
batik
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 860566, Fejl 899374.
I Mitres CVE-ordbog: CVE-2017-5662, CVE-2018-8013.
Yderligere oplysninger:

Man Yue Mo, Lars Krapf og Pierre Ernst opdagede at Batik, et værktøjssæt til behandling af SVG-billeder, ikke på korrekt vis validerede sine inddata. Dermed kunne en angriber få mulighed for at forårsage et lammelsesangreb, iværksætte angreb i forbindelse med udførelse af skripter på tværs af websteder, eller tilgå adgangsbegrænsede filer på serveren.

I den gamle stabile distribution (jessie), er disse problemer rettet i version 1.7+dfsg-5+deb8u1.

I den stabile distribution (stretch), er disse problemer rettet i version 1.8-4+deb9u1.

Vi anbefaler at du opgraderer dine batik-pakker.

For detaljeret sikkerhedsstatus vedrørende batik, se dens sikkerhedssporingsside på: https://security-tracker.debian.org/tracker/batik