Debians sikkerhedsbulletin

DSA-4283-1 ruby-json-jwt -- sikkerhedsopdatering

Rapporteret den:
31. aug 2018
Berørte pakker:
ruby-json-jwt
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2018-1000539.
Yderligere oplysninger:

Man opdagede at ruby-json-jwt, en Ruby-implementering af JSON-webtokens, udførte utilstrækkelig validering af GCM-authtags.

I den stabile distribution (stretch), er dette problem rettet i version 1.6.2-1+deb9u1.

Vi anbefaler at du opgraderer dine ruby-json-jwt-pakker.

For detaljeret sikkerhedsstatus vedrørende ruby-json-jwt, se dens sikkerhedssporingsside på: https://security-tracker.debian.org/tracker/ruby-json-jwt