Säkerhetsbulletin från Debian

DSA-4307-1 python3.5 -- säkerhetsuppdatering

Rapporterat den:
2018-09-28
Berörda paket:
python3.5
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Mitres CVE-förteckning: CVE-2017-1000158, CVE-2018-1060, CVE-2018-1061, CVE-2018-14647.
Ytterligare information:

Flera säkerhetsproblem har upptäckts i Python: ElementTree misslyckades att initiera Expat's hashsalt, två överbelastningsproblem har upptäckts i difflib och poplib och ett buffertspill påverkar PyString_DecodeEscape.

För den stabila utgåvan (Stretch) har dessa problem rättats i version 3.5.3-1+deb9u1.

Vi rekommenderar att ni uppgraderar era python3.5-paket.

För detaljerad säkerhetsstatus om python3.5 vänligen se dess säkerhetsspårare på https://security-tracker.debian.org/tracker/python3.5