데비안 보안 권고

DSA-4312-1 tinc -- 보안 업데이트

보고일:
2018년 10월 08일
영향 받는 패키지:
tinc
위험성:
보안 데이터베이스 참조:
Mitre의 CVE 사전: CVE-2018-16738, CVE-2018-16758.
추가 정보:

Several vulnerabilities were discovered in tinc, a Virtual Private Network (VPN) daemon. The Common Vulnerabilities and Exposures project identifies the following problems:

  • CVE-2018-16738

    Michael Yonli discovered a flaw in the implementation of the authentication protocol that could allow a remote attacker to establish an authenticated, one-way connection with another node.

  • CVE-2018-16758

    Michael Yonli discovered that a man-in-the-middle that has intercepted a TCP connection might be able to disable encryption of UDP packets sent by a node.

안정배포(stretch)에서, 이 문제를 버전 version 1.0.31-1+deb9u1에서 고쳤습니다.

tinc 패키지를 업그레이드 하는 게 좋습니다.

tinc의 자세한 보안 상태는 보안 추적 페이지 참조하세요: https://security-tracker.debian.org/tracker/tinc