Bulletin d'alerte Debian

DSA-4322-1 libssh -- Mise à jour de sécurité

Date du rapport :
17 octobre 2018
Paquets concernés :
libssh
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 911149.
Dans le dictionnaire CVE du Mitre : CVE-2018-10933.
Plus de précisions :

Peter Winter-Smith de NCC Group a découvert que libssh, une petite bibliothèque SSH en C, renfermait une vulnérabilité de contournement d'authentification dans le code du serveur. Un attaquant peut tirer avantage de ce défaut pour s'authentifier avec succès sans aucune identité en présentant au serveur un message SSH2_MSG_USERAUTH_SUCCESS à la place d'un message SSH2_MSG_USERAUTH_REQUEST que le serveur s'attend à recevoir pour initier l'authentification.

Pour la distribution stable (Stretch), ce problème a été corrigé dans la version 0.7.3-2+deb9u1.

Nous vous recommandons de mettre à jour vos paquets libssh.

Pour disposer d'un état détaillé sur la sécurité de libssh, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/libssh.