주의: 이 번역은 원문보다 오래되었습니다.

데비안 보안 권고

DSA-4322-1 libssh -- 보안 업데이트

보고일:
2018년 10월 17일
영향 받는 패키지:
libssh
위험성:
보안 데이터베이스 참조:
데비안 버그 추적 시스템: 버그 911149.
Mitre의 CVE 사전: CVE-2018-10933.
추가 정보:

Peter Winter-Smith of NCC Group discovered that libssh, a tiny C SSH library, contains an authentication bypass vulnerability in the server code. An attacker can take advantage of this flaw to successfully authenticate without any credentials by presenting the server an SSH2_MSG_USERAUTH_SUCCESS message in place of the SSH2_MSG_USERAUTH_REQUEST message which the server would expect to initiate authentication.

안정 배포(stretch)에서 이 문제를 0.7.3-2+deb9u1 버전에서 고쳤습니다.

libssh 패키지를 업그레이드 하는 게 좋습니다.

libssh의 자세한 보안 상태는 보안 추적 페이지를 참조하십시오: https://security-tracker.debian.org/tracker/libssh