Рекомендация Debian по безопасности

DSA-4345-1 samba -- обновление безопасности

Дата сообщения:
27.11.2018
Затронутые пакеты:
samba
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2018-14629, CVE-2018-16841, CVE-2018-16851.
Более подробная информация:

В Samba, файловом сервере, сервере печати и аутентификации SMB/CIFS для Unix, было обнаружено несколько уязвимостей. Проект Common Vulnerabilities and Exposures определяет следующие проблемы:

  • CVE-2018-14629

    Флориан Штойлпнер обнаружил, что Samba уязвима к бесконечным рекурсивным запросам, вызываемым циклами CNAME, что приводит к отказу в обслуживании.

    https://www.samba.org/samba/security/CVE-2018-14629.html

  • CVE-2018-16841

    Алекс Маккаиш обнаружил, что пользователь, имеющий действительный сертификат или смарт-карту, может аварийно завершить Samba AD DC KDC в случае, если указанная служба настроена на принятие аутентификации с помощью смарт-карт.

    https://www.samba.org/samba/security/CVE-2018-16841.html

  • CVE-2018-16851

    Гарминг Сэм из команды Samba и Catalyst обнаружил разыменование NULL-указателя в LDAP-сервере Samba AD DC, позволяющее пользователю, способному считывать более 256МБ записей LDAP, аварийно завершать работу LDAP-сервера Samba AD DC.

    https://www.samba.org/samba/security/CVE-2018-16851.html

В стабильном выпуске (stretch) эти проблемы были исправлены в версии 2:4.5.12+dfsg-2+deb9u4.

Рекомендуется обновить пакеты samba.

С подробным статусом поддержки безопасности samba можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/samba