Рекомендация Debian по безопасности

DSA-4347-1 perl -- обновление безопасности

Дата сообщения:
29.11.2018
Затронутые пакеты:
perl
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2018-18311, CVE-2018-18312, CVE-2018-18313, CVE-2018-18314.
Более подробная информация:

В реализации языка программирования Perl были обнаружены многочисленные уязвимости. Проект Common Vulnerabilities and Exposures определяет следующие проблемы:

  • CVE-2018-18311

    Джайакришна Менон и Кристоф Хайзер обнаружили переполнение целы чисел в Perl_my_setenv, приводящее к переполнению буфера при обработке входных данных злоумышленника.

  • CVE-2018-18312

    Эичи Тсуката обнаружил, что специально сформированное регулярное выражение может приводить к записи за пределами выделенного буфера памяти во время компиляции, что потенциально позволяет выполнять произвольный код.

  • CVE-2018-18313

    Эичи Тсуката обнаружил, что специально сформированное регулярное выражение может приводить к записи за пределами выделенного буфера памяти во время компиляции, что приводит к утечке информации.

  • CVE-2018-18314

    Якуб Вилк обнаружил, что специально сформированное регулярное выражение может приводить к переполнению буфера.

В стабильном выпуске (stretch) эти проблемы были исправлены в версии 5.24.1-3+deb9u5.

Рекомендуется обновить пакеты perl.

С подробным статусом поддержки безопасности perl можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/perl