Debians sikkerhedsbulletin

DSA-4382-1 rssh -- sikkerhedsopdatering

Rapporteret den:
2. feb 2019
Berørte pakker:
rssh
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2019-3463, CVE-2019-3464.
Yderligere oplysninger:

Nick Cleaton opdagede to sårbarheder i rssh, en begrænset shell der gør det muligt for brugere kun at udføre scp-, sftp-, cvs-, svnserve- (Subversion), rdist- og/eller rsync-handlinger. Manglende validering i rsync-understøttelsen kunne medføre omgåelse af denne begrænsning, gørende det muligt at udføre vilkårlige shell-kommandoer.

I den stabile distribution (stretch), er disse problemer rettet i version 2.3.4-5+deb9u2.

Vi anbefaler at du opgraderer dine rssh-pakker.

For detaljeret sikkerhedsstatus vedrørende rssh, se dens sikkerhedssporingsside på: https://security-tracker.debian.org/tracker/rssh