Рекомендация Debian по безопасности

DSA-4396-1 ansible -- обновление безопасности

Дата сообщения:
19.02.2019
Затронутые пакеты:
ansible
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2018-10855, CVE-2018-10875, CVE-2018-16837, CVE-2018-16876, CVE-2019-3828.
Более подробная информация:

В Ansible, системе настройки, управления, развёртывания и выполнения задач, было обнаружено несколько уязвимостей:

  • CVE-2018-10855 / CVE-2018-16876

    Флаг задачи no_log не учитывается, что приводит к утечке информации.

  • CVE-2018-10875

    ansible.cfg считывается из текущего рабочего каталога.

  • CVE-2018-16837

    Модуль user раскрывает параметры, передаваемые ssh-keygen окружению процесса.

  • CVE-2019-3828

    Модуль fetch может быть уязвим к обходу каталога.

В стабильном выпуске (stretch) эти проблемы были исправлены в версии 2.2.1.0-2+deb9u1.

Рекомендуется обновить пакеты ansible.

С подробным статусом поддержки безопасности ansible можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/ansible