Aviso de seguridad de Debian

DSA-4405-1 openjpeg2 -- actualización de seguridad

Fecha del informe:
10 de mar de 2019
Paquetes afectados:
openjpeg2
Vulnerable:
Referencias a bases de datos de seguridad:
En el sistema de seguimiento de errores de Debian: error 884738, error 888533, error 889683, error 904873, error 910763.
En el diccionario CVE de Mitre: CVE-2017-17480, CVE-2018-5785, CVE-2018-6616, CVE-2018-14423, CVE-2018-18088.
Información adicional:

Se han descubierto múltiples vulnerabilidades en openjpeg2, el codec JPEG 2000 de código abierto, que podrían utilizarse para provocar denegación de servicio o, posiblemente, ejecución de código remoto.

  • CVE-2017-17480

    Un desbordamiento de escritura en la pila en los codecs jp3d y jpwl puede dar lugar a denegación de servicio o a ejecución de código remoto a través de un fichero jp3d o jpwl manipulado.

  • CVE-2018-5785

    Un desbordamiento de entero puede dar lugar a denegación de servicio por medio de un fichero bmp manipulado.

  • CVE-2018-6616

    Un exceso de iteraciones puede dar lugar a denegación de servicio vía un fichero bmp manipulado.

  • CVE-2018-14423

    Vulnerabilidades de división por cero pueden dar lugar a denegación de servicio a través de un fichero j2k manipulado.

  • CVE-2018-18088

    Una desreferencia de puntero nulo puede dar lugar a denegación de servicio por medio de un fichero bmp manipulado.

Para la distribución «estable» (stretch), estos problemas se han corregido en la versión 2.1.2-1.1+deb9u3.

Le recomendamos que actualice los paquetes de openjpeg2.

Para información detallada sobre el estado de seguridad de openjpeg2, consulte su página en el sistema de seguimiento de problemas de seguridad: https://security-tracker.debian.org/tracker/openjpeg2