Рекомендация Debian по безопасности

DSA-4405-1 openjpeg2 -- обновление безопасности

Дата сообщения:
10.03.2019
Затронутые пакеты:
openjpeg2
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 884738, Ошибка 888533, Ошибка 889683, Ошибка 904873, Ошибка 910763.
В каталоге Mitre CVE: CVE-2017-17480, CVE-2018-5785, CVE-2018-6616, CVE-2018-14423, CVE-2018-18088.
Более подробная информация:

В openjpeg2, кодеке JPEG 2000 с открытым исходным кодом, были обнаружены многочисленные уязвимости, которые могут использоваться для вызова отказа в обслуживании или удалённого выполнения кода.

  • CVE-2017-17480

    Запись за пределы выделенного буфера памяти в кодеках jp3d и jpwl могут приводить к отказу в обслуживании или удалённому выполнению кода при обработке специально сформированных файлов jp3d или jpwl.

  • CVE-2018-5785

    Переполнение целых чисел может приводить к отказу в обслуживании при обработке специально сформированного файла bmp.

  • CVE-2018-6616

    Избыточная итерация может приводить к отказу в обслуживании при обработке специально сформированного файла bmp.

  • CVE-2018-14423

    Деление на ноль может приводить к отказу в обслуживании при обработке специально сформированного файла j2k.

  • CVE-2018-18088

    Разыменование null-указателя может приводить к отказу в обслуживании при обработке специально сформированного файла bmp.

В стабильном выпуске (stretch) эти проблемы были исправлены в версии 2.1.2-1.1+deb9u3.

Рекомендуется обновить пакеты openjpeg2.

С подробным статусом поддержки безопасности openjpeg2 можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/openjpeg2