Рекомендация Debian по безопасности

DSA-4414-1 libapache2-mod-auth-mellon -- обновление безопасности

Дата сообщения:
23.03.2019
Затронутые пакеты:
libapache2-mod-auth-mellon
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 925197.
В каталоге Mitre CVE: CVE-2019-3877, CVE-2019-3878.
Более подробная информация:

В Apache-модуле auth_mellon, предоставляющем аутентификацию SAML 2.0, было обнаружено несколько проблем.

  • CVE-2019-3877

    Можно обойти проверку URL при перенаправлении во время выхода, поэтому модуль может использоваться в качестве открытого средства перенаправления.

  • CVE-2019-3878

    При использовании опции mod_auth_mellon в настройках Apache, служащей в качестве удалённого прокси с модулем http_proxy, можно обходить аутентификацию путём отправки ECP-заголовков SAML.

В стабильном выпуске (stretch) эти проблемы были исправлены в версии 0.12.0-2+deb9u1.

Рекомендуется обновить пакеты libapache2-mod-auth-mellon.

С подробным статусом поддержки безопасности libapache2-mod-auth-mellon можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/libapache2-mod-auth-mellon