데비안 보안 권고

DSA-4424-1 pdns -- 보안 업데이트

보고일:
2019년 04월 04일
영향 받는 패키지:
pdns
위험성:
보안 데이터베이스 참조:
데비안 버그 추적 시스템: 버그 924966.
Mitre의 CVE 사전: CVE-2019-3871.
추가 정보:

Adam Dobrawy, Frederico Silva and Gregory Brzeski from HyperOne.com discovered that pdns, an authoritative DNS server, did not properly validate user-supplied data when building a HTTP request from a DNS query in the HTTP Connector of the Remote backend. This would allow a remote user to cause either a denial-of-service, or information disclosure.

안정배포(stretch)에서 이 문제를 버전 4.0.3-1+deb9u4에서 고쳤습니다.

pdns 패키지를 업그레이드 하는 게 좋습니다.

pdns의 자세한 보안 상태는 보안 추적 페이지 참조: https://security-tracker.debian.org/tracker/pdns