Рекомендация Debian по безопасности

DSA-4431-1 libssh2 -- обновление безопасности

Дата сообщения:
13.04.2019
Затронутые пакеты:
libssh2
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 924965.
В каталоге Mitre CVE: CVE-2019-3855, CVE-2019-3856, CVE-2019-3857, CVE-2019-3858, CVE-2019-3859, CVE-2019-3860, CVE-2019-3861, CVE-2019-3862, CVE-2019-3863.
Более подробная информация:

Крис Коулсон обнаружил несколько уязвимостей в libssh2, клиентской библиотеке SSH2, которые могут приводить к отказу в обслуживании, утечкам информации или выполнению произвольного кода.

В стабильном выпуске (stretch) эти проблемы были исправлены в версии 1.7.0-1+deb9u1.

Рекомендуется обновить пакеты libssh2.

С подробным статусом поддержки безопасности libssh2 можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/libssh2